1

Тема: Bootstrap 3.3.7

Всем привет.
Кому не трудно выложите пошаговую инструкцию по подключению к Micron (у) Bootstrap 3.3.7.
На этом сайте инструкция про старый Bootstrap.
Заранее благодарю.

Re: Bootstrap 3.3.7

Какой старый? Если так смотреть, то и 3.3.7 старый, потому  что,  уже 4 бутстрап вышел. Это раз. Два - ничего подключать не надо, достаточно просто поменять less-файлы. Но смысла нет, там и так файлы 3 бутстрапа, они практически ничем не отличаются.

3

Re: Bootstrap 3.3.7

Понял спасибо !

4 (2016-11-24 12:46:38 отредактировано indigo_brise)

Re: Bootstrap 3.3.7

По моему мнению обновление до Bootstrap 3.3.7 по схеме залить less и в файле Bootstrap3.php поменять пути уже не катит. Лично я как только не изменял у меня по логам выходит ошибка:

Text notification:
    subject: E_ERROR: Uncaught exception 'Exception' with message 'parse error: failed at `&:extend(.clearfix all); ` line: 4288' in /home/i/indi/САЙТ.ru/public_html/lib/ExtraPacker/Lib/lessc.inc.php:3460 at /home/i/indi/САЙТ.ru/public_html/lib/ExtraPacker/Lib/lessc.inc.php on line 3460
    //САЙТ.ru/
E_ERROR: Uncaught exception 'Exception' with message 'parse error: failed at `&:extend(.clearfix all); ` line: 4288' in /home/i/indi/САЙТ.ru/public_html/lib/ExtraPacker/Lib/lessc.inc.php:3460
Stack trace:
#0 /home/i/indi/САЙТ.ru/public_html/lib/ExtraPacker/Lib/lessc.inc.php(2273): lessc_parser->throwError()
#1 /home/i/indi/САЙТ.ru/public_html/lib/ExtraPacker/Lib/lessc.inc.php(1795): lessc_parser->parse('?    .m-border-...')
#2 /home/i/indi/САЙТ.ru/public_html/lib/ExtraPacker/Lib/lessc.inc.php(1934): lessc->compile('?    .m-border-...')
#3 /home/i/indi/САЙТ.ru/public_html/lib/ExtraPacker/ExtraPacker.php(300): lessc->parse('?    .m-border-...')
#4 /home/i/indi/САЙТ.ru/public_html/lib/ExtraPacker/ExtraPacker.php(587): ExtraPacker->WriteDataInCache('css', Array, Array)
#5 /home/i/indi/САЙТ.ru/public_html/lib/ExtraPacker/ExtraPacker.php(670): ExtraPacker->CssPack('<!DOCTYPE html>...')
#6 /home/i/indi/САЙТ.ru/public_html/core/func/main.php(267): ExtraPacker->Pack('<!DOCTYPE html>...')
#7 [int
at /home/i/indi/САЙТ.ru/public_html/lib/ExtraPacker/Lib/lessc.inc.php on line 3460

Если у кого получалось обновить (именно до 3.3.7) или кто может сказать куда глядеть и можно ли что либо сделать, буду очень признателен вашим ответам.

Re: Bootstrap 3.3.7

если так уж сильно горит, то можно использовать уже скомпилированный bootstrap css вместо less, тогда будет работать

6 (2016-11-24 14:59:50 отредактировано indigo_brise)

Re: Bootstrap 3.3.7

Так и сделал, в bootstrap3.php вместо less прописал css и js 3.3.7 версии, почистил ненужные файлы.
PS не горит, но нравится когда все обновления можно делать без затруднений) Спасибо за ответ!

Re: Bootstrap 3.3.7

а зачем в bootstrap3 надо было прописывать? его можно было просто в tpl прописать, только лишние инклюды плодить. тплка инклюдит bootstrap3.php, он инклюдит файл стилей, зачем такие кривые пути непонятно. А ненужные файлы там все файлы в компоненте bootstrap3, вся эта куча less и js

8 (2016-11-24 16:00:09 отредактировано indigo_brise)

Re: Bootstrap 3.3.7

Да, можно прописать в tpl напрямую, но я прописал в bootstrap3.php т.к. в других установленных компонентах зависимых от стилей бутстрапа уже идет инклюдит на данный php файл, и что бы не искать и не менять в каждом файле их с <?php IncludeCom('dev/bootstrap3')?> на link rel css и js, пока оставил так. Думаю не особо это скажется на производительности сайта.

Re: Bootstrap 3.3.7

10 компонентов - 10 инклюдов.  проще удалить в кадом, чем инклюдить окольными путями файл, который ожно вставить один раз в main_tpl. ТАк быо сделано, потому что в нескомпилированном виде бутсрап из себя представляет кучу файлов и в main_tpl  это бы вызывало неудобства. а так... хз, на фига так через одно место делать